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WebMail & WebQuarantine Login Issues

Product:
All

Version & Build: All

 

 

General Description:

 

When attempting to log into WebMail or WebQuarantine, you get an error similar to the following:

 

Server Error in '/Quarantine' Application

0xE0020101

0xE0020104

 

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

 

 

 

Cause:

 

The Web program is attempting to connect to the SMTP server with an incorrect IP address. Either an invalid IP address was entered or your network configuration has changed and the IP addresses were not updated for the Web program.

 

Reminder: Any IP address change on the Modus server is not automatically inherited by WebMail or WebQuarantine and must be configured manually in the Web program files.

 

 

Solution:

 

  • ModusGate
    • In Windows Explorer, go to …\Vircom\ModusGate\Web\WebQuarantine and open the webmailsvr.ini file with Notepad
    • Under [RPC:Settings], verify the Host IP address under
      • This should be the first static IP address of the server (from the first NIC card if there are multiple NICs installed)
      • Save the file if a change is made
    • Verify if the machine is able to resolve the loopback address (127.0.0.1) entered for the SMTP, POP and IMAP connections
      • If your firewall or network security does not permit the use of this IP address, replace it in the webmailsvr.ini file with either "localhost or the actual static IP of the server
      • Save the file is a change is made
    • Stop and start the WEBMAILSVR service

 

  • ModusMail

 

    • In Windows Explorer, go to …\Vircom\ModusMail\Web\WebMail and open the webmailsvr.ini file with Notepad
    • Under [RPC:Settings], verify the Host IP address under
      • This should be the first static IP address of the server (from the first NIC card if there are multiple NICs installed)
      • Save the file if a change is made
    • Verify if the machine is able to resolve the loopback address (127.0.0.1) entered for the SMTP, POP and IMAP connections
      • If your firewall or network security does not permit the use of this IP address, replace it in the webmailsvr.ini file with either "localhost or the actual static IP of the server
      • Save the file is a change is made
    • Stop and start the WEBMAILSVR service

 

Modified 7/8/2008
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Article ID: 1088